Texlipse

Rechtschreibprüfung in Texlipse

Auf der Suche nach einem guten LaTeX-Editor welcher unter Linux lauffähig ist, bin ich vor einiger Zeit auf das Eclipse Plugin TeXlipse gestoßen. Seit kurzer Zeit benutze ich das auch wieder intensiv. Beim kopieren und einfügen scheint zwar manchmal ein Bug aufzutreten, den ich noch nicht näher einordnen konnte, ansonsten entdeckt man aber ständig neue, praktische Features.

Beispielsweise kann über Shift+Ctrl+6 (im Menü LaTeX: Check Spelling) die Rechtschreibprüfung aspell aufgerufen werden. Falsche Wörter werden dann unterstrichen. Mit Strg+Leertaste kann man dann die Korrekturvorschläge abrufen oder neue Wörter dem Wöterbuch hinzufügen.


9 Gedanken zu „Texlipse

  1. Philipp

    Nachdem ich zwei andere Plugins deaktiviert hatte läuft Texlipse nun auch bei mir. Jedoch hat er erst noch wegen jedem Umlaut einen Fehler angezeigt:
    „LaTeX Error: Command \textcurrency unavailable in encoding OT1.“

    Das Problem lag daran das ich mein Eclipse auf UTF8 gestellt hab. Deswegen muss man \usepackage[utf8]{inputenc} anstelle von \usepackage[latin1]{inputenc} für die Umlaute verwenden.

    Antworten
  2. mary

    Hallo Ihr, nochmal ne Frage: ich habe auch ständig (und mit wachsendem Dokument öfter) diesen Copy-Paste-Bug. Wie habt Ihr den denn weggebracht?

    Danke
    Mary

    Antworten
  3. mary

    Also ich habe den Bug immer noch – unter Vista nun vermehrt. Ich hab dem Autor das noch nicht mitgeteilt.

    Antworten
  4. self Artikelautor

    Ähm, welche Version verwendest du denn ? Auf http://texlipse.sourceforge.net/ lese ich gerade:

    25.11.2007: Version 1.2.1 released

    This version is a bug fix release. It fixes a critical bug that let Eclipse freeze in some rare occasions. Additionately an annoying bug which occurs while pasting text in hardlinewrap mode was fixed.

    Antworten
  5. Patrick

    Ich versuche die ganze Zeit eine Rechtschreibprüfung hinzubekommen, die von Eclipse (Prefs => Spelling), geht nur ab und zu und zeigt bei mir auch immer alle Worte mit Umlauten als Falsch an (Eclipse UTF8, \usepackage[utf8]{inputenc} ), die von Texlipse (Prefs => Texlipse => Spell) bekomme ich garnicht zum laufen (und Texniccenter zeig mir die Umlaute nicht richtig an).
    Jemand ne Idee? Bin echt am verzweifeln.

    Antworten
  6. Sascha

    @Patrick:
    Hatte das Gleiche Problem.

    stell mal das encoding in TEXLIPSE auf ISO… um, also in den Einstellungen von Texlipse->Spell Checker->Aspell Argumente:
    -a -t –lang=%language –encoding=iso8859-1

    Frag mich nicht warum, aber dann ging es bei mir

    Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.